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В связи с новыми разработками в течение 
2014-го года появились и новые возможности 
для организации наблюдений с 
использованием программ zeiss_list, 
Stellarium, XEphem, а также клиента GCN.
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Использование zeiss_list.

Программа предназначена для простой графической работы со списками объектов. Она 
разработана на основе используемой в интерфейсе АСУ БТА программы bta_list. Соответственно 
использует тот же привычный наблюдателям формат списка объектов. 

Сразу после запуска нужно задать имя и пароль пользователя и нажать «Connect». (Note: когда 
программа запускается на удаленной машине, нужно еще поменять «localhost» на сетевое имя 
машины управления.) Если использовано имя пользователя с уровнем доступа <4, то «Connect» 
будет заменено на «Send to TCS», если же уровень доступа ≥4, то на «Go To Object». В первом 
случае нажатие будет только послать координаты помеченного объекта в систему управления (и 
нужно в интерфейсе наблюдателя на вкладке «  Object  »   нажать «GoToObject»). Во втором случае 
телескоп сразу начнет наводится.

http://www.sao.ru/hq/vsher/
http://www.sao.ru/hq/vsher/Z1000/zeiss_gui.html#object
http://www.sao.ru/hq/vsher/Z1000/zeiss_gui.html#object
http://www.sao.ru/hq/vsher/Z1000/zeiss_gui.html#object
http://www.sao.ru/hq/vsher/GCN/
http://www.sao.ru/hq/vsher/reports/report2014/#zeiss
http://www.sao.ru/hq/vsher/reports/report2014/#zeiss


Программа может показывать границу наблюдаемой области из файлов линии горизонта Цейсс-
1000 подготовленных для XEphem т.е. zeiss_horizon_dir.hzn и zeiss_horizon_rev.hzn в справочнике 
~/XEphem или ~/.xephem.

Расположение объектов либо в стиле «БТА» (юг вверху), либо в стиле ТВ-камеры «AllSky» (север 
вверху). Сетка может рисоваться либо по координатам RA/Dec, либо по Азимут/Z.

Кнопка «Catalogs» показывает меню подключенных каталогов. Часть из них унаследована с БТА 
(в ~/AstroList/, традиционно это ссылка: AstroList->/usr/local/lib/AstroList), а часть может 
добавляться из XEphem (если они записаны в ~/Xephem/ или ~/.xephem/ в формате edb).

Кроме унаследованного от БТА формата списка объектов (.lst), программа понимает и формат 
каталогов «неподвижных» объектов из XEphem (.edb). Браузер файлов для поиска списков 
объектов вызывается кнопкой «Get list». По-умолчанию показываются списки *.lst, если нужны 
*.edb следует переключить фильтр «File type». 

Рекомендуется готовить списки объектов в формате edb. Для «неподвижных» объектов он 
простой, а использовать их тогда можно и в этой программе и в XEphem. Поля в формате edb 
разделяются запятой. Если поле нужно еще разбить на под-поля используется вертикальная черта 
«|». Первое поле — имя объекта. Второе — тип, в нашем случае «f» - fixed. Третье — RA в 
формате hh:mm:ss.ss. Четвертое - Dec в формате ±dd:mm:ss.s. Пятое — звездная величина (если 
неизвестна пишут 99.9). Шестое -эпоха координат.

Наример строка формата lst для Полярной звезды:

02 31 48.7 : +89 15 50.7 : 2000.0 # Alpha U Mi  2.02

может быть переписана в формат edb как: 

Alp U Mi|Polaris, f, 2:31:48.7, +89:15:50.7, 2.02, 2000.0

Для программы zeiss_list обязательны только первые четыре поля.



Использование Stellarium.

Описанная выше zeiss_list , также как и XEphem, могут вызываться удаленно через X11. В отличие 
от них такое использование компьютерного планетария Stellarium затруднительно. Он работает в 
видео-режиме, т.е. фактически показывает мультфильм. Поэтому нормально им можно 
пользоваться только на дисплее того компьютера где он установлен. Stellarium есть под разные 
ОС: Windows, Apple OS X, Linux/Unix. Связь с телескопами возможна через Интернет. Для этого в 
машине управления телескопа должен работать TCP-сервер реализующий протокол связи 
Stellarium. Один Stellarium может контролировать сразу несколько телескопов. TCP-сервер 
Stellarium для Цейсс-1000 разработан, называется — zeiss1000stellarium. При запуске у него один 
обязательный параметр — TCP-порт по которому будет обращаться Stellarium (сейчас это 10000). 
Может добавляться и второй необязательный параметр: URL связи с XML-RPC-сервером 
телескопа (http://user:passwd@hostname:8088). По-умолчанию — локальный компьютер и 2-й 
уровень доступа.

Если все настройки Stellarium сделаны правильно и работает его TCP-сервер телескопов 
(zeiss1000stellarium для Цейсс-1000), то на экране показывается текущее положение телескопа. 
Если кликом мышки выделить объект и нажать на клавиатуре Ctrl+1, координаты объекта будут 
переданы системе управления телескопа. Останется только в интерфейсе наблюдателя на вкладке 
«  Object  »   нажать «GoToObject».

http://www.sao.ru/hq/vsher/Z1000/zeiss_gui.html#object
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http://www.sao.ru/hq/vsher/Z1000/zeiss_gui.html#object
http://www.stellarium.org/ru/
http://www.clearskyinstitute.com/xephem/
http://www.stellarium.org/ru/


Использование XEphem.

После разработки программы zeiss1000xed, реализующей FIFO-канал связи с телескопом для 
XEphem, появилась возможность использования всех его возможностей и многочисленных 
каталогов. Программа zeiss1000xed должна работать на той же машине что и XEphem, а с Цейсс-
1000 может связываться по сети. zeiss1000xed имитирует программы связи XEphem с 
любительскими телескопами (типа Meade LX200). Ключи вызова соответственно аналогичные (-h 
— help). Параметр «-t http://user:passwd@hostname:8088» — для связи с XML-RPC-сервером 
телескопа. Без параметров — локальный компьютер и 2-й уровень доступа. Если программа связи 
работает, то в окне Sky View появляется маркер положения телескопа, а в контекстном меню 
объекта появляется элемент «Telescope GoTo».

Такая же кнопка есть в окне для работы с загруженными каталогами. Это позволяет передавать 
данные об объекте программе связи, а она перешлет их системе управления телескопа.

Для установленного на управляющем компьютере ztcs версии XЕphem-3.5 программа связи 
вызывается из окна View->Sky View->Telescope->Configure:

Нужно включить кнопку Running и нажать Ok в окне подтверждения. Для отключения связи 
выключить кнопку Running. На других компьютерах в более новых версиях XEphem (с INDI-
интерфейсом) такой настройки нет, но FIFO-канал поддерживается. Там программу связи нужно 

http://www.clearskyinstitute.com/xephem/
http://www.clearskyinstitute.com/xephem/


запускать из отдельного окна терминала. Если для связи с сервером телескопа используется имя 
пользователя с уровнем доступа ≥4 (опытный наблюдатель), то при использовании «Telescope 
GoTo» в контекстном меню объекта, телескоп сразу начнет наводиться. Иначе выполняется только 
посылка (Send) координат, а стартовать наведение нужно из интерфейса наблюдателя.

Для представления линии горизонта изготовлены два файла: zeiss_horizon_dir.hzn — для 
нормальной моды наблюдений и zeiss_horizon_rev.hzn — для работы с перекладкой. Они должны 
находится у пользователя в справочнике XEphem (или .xephem в новых версиях). Туда же 
помещаются и дополнительные каталоги формата edb, а также пользовательские списки объектов 
в этом формате.

Подробное описание формата edb можно прочесть в File format (XEphem Reference Manual). Для 
«неподвижных» объектов, он достаточно простой. Поля (Fields) разделяются запятой. Если в поле 
есть под-поля (SubFields) они отделяются вертикальной чертой «|».

1. Имя (или имена, если несколько, через «|») объекта.

2. Тип объекта (формата строки), в нашем случае всегда «f» - fixed. Через «|» могут 
добавляться одно или два под-поля:

• Класс объекта. Например: S — звезды, D — двойные звезды, M — кратные звезды, 
Q — квазары и AGN, G — галактики и т.д.

• Для звезд еще может быть спектральный класс. Например: A2, B8, F7.

3. RA в формате hh:mm:ss.ss. Возможно SubField - собственное движение mas/год по небу, т.е. 
ΔRA*cos(Dec).

4. Dec в формате ±dd:mm:ss.s. Возможно SubField - собственное движение mas/год.

5. Звездная величина (если неизвестна пишут 99.9). 

http://www.clearskyinstitute.com/xephem/help/xephem.html#mozTocId468501
http://www.sao.ru/hq/vsher/Z1000/zeiss_gui.html#object


6. Эпоха координат. Например: 2000 или 1950.0. Если отсутствует, по-умолчанию 2000.0.

7. Видимый размер объекта в угл.секундах. По-умолчанию 0.0.

Общие (shared) каталоги размещаются в /usr/lib/xephem/catalogs/ (или /usr/local/xephem/catalogs/ в 
зависимости от установки XЕphem в систему). Личные (private) — находятся у пользователя (в 
Home) в справочнике XEphem (или .xephem в новых версиях). Меню Data->Load/Delete local files... 
вызывает окно для смены используемых каталогов.

Кроме того можно подключать некоторые большие каталоги как «Звезды Поля» (Field Stars). Это 
окно вызывается как Data->Configure Field stars... Сейчас на управляющем компьютере ztcs 
имеются и можно подключать: HST GSC, USNO-A2, PPM и комбинацию Hipparcos+Tycho2. GSC 
и USNO воспринимаются в их собственном дистрибутивном формате. Для остальных больших 
каталогов XEphem использует собственный двоичный упакованный формат xe2.

XЕphem также может работать и с edb-каталогами объектов солнечной системы (кометы, 
астероиды) и околоземных (ИЗС). В этом случае в каталоге записаны стандартные элементы 
орбиты. Эти каталоги быстро «стареют», поэтому XEphem предоставляет средство для их закачки. 
Окно вызывается из меню Data->Download...



При этом каталоги формата TLE автоматически преобразуются в edb и записываются в private-
справочник пользователя. К сожалению, хотя у XEphem есть настройка сетевой работы через 
proxy-сервер, закачка таким способом работает плохо (либо вообще не работает). Т.е. компьютер 
должен иметь прямой выход в Интернет хотя бы через NAT или VPN. Поэтому, если нужно 
использовать XEphem (для наблюдений комет и астероидов) на самом управляющем компьютере 
ztcs, то закачка выполняется на другом компьютере с Интернет-выходом , а затем уже готовые 
edb-файлы переписываются в private-справочник на ztcs.

Каталоги комет и астероидов желательно иметь не старее 1-го месяца (т.е. обновлять перед сетом 
наблюдений), а каталоги ИЗС — 1-го дня (т.е. обновлять перед каждой ночью).

Программа связи с телескопом zeiss1000xed также воспринимает edb-форматы для «подвижных» 
объектов. В этом случае она по заданным элементам орбиты рассчитывает не только текущие 
координаты, но и скорости смещения по RA и Dec. Все это выполняется по «Telescope GoTo» в 
контекстном меню объекта. Рассчитанные стартовые параметры передаются серверу. Если объект 
быстро меняет скорости смещения (т.е. очень близкий астероид или Луна или ИЗС), то они 
периодически пересчитываются и передаются в систему управления Цейсс-1000. Это 
обеспечивает точное сопровождение «движущихся» объектов телескопом. Разумеется уровень 
доступа пользователя для такой работы должен быть ≥4 (для передачи только стартовых 
параметров достаточно 3-го).

Примеры использования XEphem.

Пример наблюдения кометы 154P/Brewington зимой 2014-го года.



В память загружен каталог Soft03Cmt предварительно скачанный из MinorPlanetCenter. Комета 
выбирается либо по каталогу, либо на Sky View. Программа zeiss1000xed была перезагружена для 
пользователя с уровнем доступа ≥4 (на картинке не показано). После «Telescope GoTo» телескоп 
навелся. 

Имя объекта: «154P/Brewington(Periodic comet,Dist:1.624AU,Mag:10.4)», установленные скорости 
смещения: по RA — 0.00195(s/сек), по Dec — 0.01015("/сек).

На Windows-ресурсе \\ztcs\ZEISS\ZFITS.HDR формируется (и обновляется каждую секунду) 
прототип FITS-шапки для включения в FITS-файлы системы регистрации.

smb://ztcs/ZEISS/ZFITS.HDR


Снимок на CCD-фотометре с экспозицией 5минут. Видны треки звезд т.к. телескоп отслеживает 
комету.

Была также сделана попытка наведения на ИЗС. С сайта CelesTrak.com загружен каталог NORAD 
gps-ops. В окне Sky View был выбран спутник GPS PRN-13 и с помощью «Telescope GoTo» 
телескоп был отправлен догонять его.



Во время сопровождения спутника в интерфейсе наблюдателя на вкладке   Drives   видна совместная 
работа двух двигателей коррекции по Decl, а по НА двигатель часового ведения идет в обратную 
сторону.

Это четыре кадра с камеры на 20-см. гида Цейса во время сопровождения спутника. Экспозиции 
(сложение ТВ-кадров) 1минута.

http://www.sao.ru/hq/vsher/Z1000/zeiss_gui.html#drives
http://www.sao.ru/hq/vsher/Z1000/zeiss_gui.html#drives


Снимок на CCD-фотометре Цейсс-1000. Экспозиция 1сек. По трекам звезд видно что движение 
вслед за спутником не идеальное, есть легкая раскачка. 

Попытки наблюдать другие спутники показали что в своем текущем состоянии Цейсс-1000 может 
более-менее хорошо сопровождать только «высокие» спутники: GPS, ГЛОНАСС и выше. Хорошо 
отслеживаются геостационары. Это объекты у которых скорость смещения по небу укладывается 
в пределы двигателей 2-й ступени коррекции. Двигатели 1-й ступени коррекции плохо держат 
заданную скорость. Поэтому более низколетящие, а значит более «быстрые» спутники 
сопровождаются плохо.

Использование клиента GCN gcn_monitor.py.

Программа написана на языке Python и предназначена для оперативных 
наблюдений GRB-событий. Подробное описание можно прочесть в документе 
«GCN-клиент для телескопов САО» или в PDF-документе.

http://www.sao.ru/hq/vsher/GCN/gcn4sao.pdf
http://www.sao.ru/hq/vsher/GCN/
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